<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://charity.wtf/xmlrpc.php">

<title>How can you tell if the company you&#8217;re interviewing with is rotten on the inside? &#8211; charity.wtf</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="charity.wtf &raquo; Feed" href="https://charity.wtf/feed/" />
<link rel="alternate" type="application/rss+xml" title="charity.wtf &raquo; Comments Feed" href="https://charity.wtf/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="charity.wtf &raquo; How can you tell if the company you&#8217;re interviewing with is rotten on the inside? Comments Feed" href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/charity.wtf\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.9/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='genericons-css'  href='https://charity.wtf/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='minnow-style-css'  href='https://charity.wtf/wp-content/themes/minnow/style.css?ver=5.9' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='minnow-opensans-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%2C700italic%2C400italic%2C300italic%7COpen+Sans+Condensed%3A700%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css' type='text/css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://charity.wtf/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.6-beta' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://charity.wtf/wp-content/plugins/jetpack/css/jetpack.css?ver=10.6-beta' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://charity.wtf/wp-json/" /><link rel="alternate" type="application/json" href="https://charity.wtf/wp-json/wp/v2/posts/7561" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://charity.wtf/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://charity.wtf/wp-includes/wlwmanifest.xml" /> 

<link rel="canonical" href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/" />
<link rel='shortlink' href='https://wp.me/p74lOS-1XX' />
<link rel="alternate" type="application/json+oembed" href="https://charity.wtf/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://charity.wtf/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
			<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="description" content="How can you tell the companies who are earnestly trying to improve apart from the ones who sound all polished and healthy from the outside, whilst rotting on the inside? This seems to be on a lot of minds right now, what with the Great Resignation and all. There are no perfect companies, just like&hellip;" />
<link rel="amphtml" href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/amp/">			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="How can you tell if the company you&#8217;re interviewing with is rotten on the inside?" />
<meta property="og:url" content="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/" />
<meta property="og:description" content="How can you tell the companies who are earnestly trying to improve apart from the ones who sound all polished and healthy from the outside, whilst rotting on the inside? This seems to be on a lot o…" />
<meta property="article:published_time" content="2022-01-29T02:05:52+00:00" />
<meta property="article:modified_time" content="2022-01-29T05:55:24+00:00" />
<meta property="og:site_name" content="charity.wtf" />
<meta property="og:image" content="https://i0.wp.com/charity.wtf/wp-content/uploads/2021/01/mepurp-15.jpg?fit=902%2C1200&#038;ssl=1" />
<meta property="og:image:width" content="902" />
<meta property="og:image:height" content="1200" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="How can you tell if the company you&#8217;re interviewing with is rotten on the inside?" />
<meta name="twitter:image" content="https://i0.wp.com/charity.wtf/wp-content/uploads/2021/01/mepurp-15.jpg?fit=902%2C1200&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="32x32" />
<link rel="icon" href="https://s0.wp.com/i/webclip.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://s0.wp.com/i/webclip.png" />
<meta name="msapplication-TileImage" content="https://s0.wp.com/i/webclip.png" />
<style type="text/css" id="wp-custom-css">blockquote {font-size: 13px;}</style><!-- Your Google Analytics Plugin is missing the tracking ID -->
</head>

<body class="post-template-default single single-post postid-7561 single-format-standard">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		<div class="site-branding">
							<a href="https://charity.wtf/" class="site-logo-link" rel="home" itemprop="url"></a>						<h1 class="site-title"><a href="https://charity.wtf/" rel="home">charity.wtf</a></h1>
			<h2 class="site-description">charity wtf&#039;s about technology, databases, startups, engineering management, and whiskey.</h2>
		</div>

		
					<button class="menu-toggle" title="Sidebar"><span class="screen-reader-text">Sidebar</span></button>
				<div class="slide-menu">
			
			
<div id="secondary" class="widget-area clear" role="complementary">
	<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">Pages</h1>
			<ul>
				<li class="page_item page-item-1"><a href="https://charity.wtf/about/">About me</a></li>
			</ul>

			</aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/" aria-current="page">How can you tell if the company you&#8217;re interviewing with is rotten on the inside?</a>
									</li>
											<li>
					<a href="https://charity.wtf/2022/01/20/how-engineering-driven-leads-to-engineering-supremacy/">How &#8220;Engineering-Driven&#8221; Leads to &#8220;Engineering-Supremacy&#8221;</a>
									</li>
											<li>
					<a href="https://charity.wtf/2021/08/27/why-i-hate-the-phrase-breaking-down-silos/">Why I hate the phrase &#8220;breaking down silos&#8221;</a>
									</li>
											<li>
					<a href="https://charity.wtf/2021/08/27/software-deploys-and-cognitive-biases/">Software deploys and cognitive biases</a>
									</li>
											<li>
					<a href="https://charity.wtf/2021/08/21/why-every-software-engineering-interview-should-include-ops-questions/">Why every software engineering interview should include ops questions</a>
									</li>
					</ul>

		</aside><aside id="archives-2" class="widget widget_archive"><h1 class="widget-title">Archives</h1>
			<ul>
					<li><a href='https://charity.wtf/2022/01/'>January 2022</a></li>
	<li><a href='https://charity.wtf/2021/08/'>August 2021</a></li>
	<li><a href='https://charity.wtf/2021/04/'>April 2021</a></li>
	<li><a href='https://charity.wtf/2021/03/'>March 2021</a></li>
	<li><a href='https://charity.wtf/2021/02/'>February 2021</a></li>
	<li><a href='https://charity.wtf/2021/01/'>January 2021</a></li>
	<li><a href='https://charity.wtf/2020/12/'>December 2020</a></li>
	<li><a href='https://charity.wtf/2020/11/'>November 2020</a></li>
	<li><a href='https://charity.wtf/2020/10/'>October 2020</a></li>
	<li><a href='https://charity.wtf/2020/09/'>September 2020</a></li>
	<li><a href='https://charity.wtf/2020/07/'>July 2020</a></li>
	<li><a href='https://charity.wtf/2020/05/'>May 2020</a></li>
	<li><a href='https://charity.wtf/2020/04/'>April 2020</a></li>
	<li><a href='https://charity.wtf/2020/03/'>March 2020</a></li>
	<li><a href='https://charity.wtf/2019/12/'>December 2019</a></li>
	<li><a href='https://charity.wtf/2019/11/'>November 2019</a></li>
	<li><a href='https://charity.wtf/2019/10/'>October 2019</a></li>
	<li><a href='https://charity.wtf/2019/09/'>September 2019</a></li>
	<li><a href='https://charity.wtf/2019/05/'>May 2019</a></li>
	<li><a href='https://charity.wtf/2019/04/'>April 2019</a></li>
	<li><a href='https://charity.wtf/2019/02/'>February 2019</a></li>
	<li><a href='https://charity.wtf/2019/01/'>January 2019</a></li>
	<li><a href='https://charity.wtf/2018/12/'>December 2018</a></li>
	<li><a href='https://charity.wtf/2018/10/'>October 2018</a></li>
	<li><a href='https://charity.wtf/2018/08/'>August 2018</a></li>
	<li><a href='https://charity.wtf/2018/03/'>March 2018</a></li>
	<li><a href='https://charity.wtf/2018/02/'>February 2018</a></li>
	<li><a href='https://charity.wtf/2017/05/'>May 2017</a></li>
	<li><a href='https://charity.wtf/2016/10/'>October 2016</a></li>
	<li><a href='https://charity.wtf/2016/06/'>June 2016</a></li>
	<li><a href='https://charity.wtf/2016/05/'>May 2016</a></li>
	<li><a href='https://charity.wtf/2016/04/'>April 2016</a></li>
	<li><a href='https://charity.wtf/2016/03/'>March 2016</a></li>
	<li><a href='https://charity.wtf/2016/02/'>February 2016</a></li>
	<li><a href='https://charity.wtf/2015/12/'>December 2015</a></li>
			</ul>

			</aside><aside id="categories-2" class="widget widget_categories"><h1 class="widget-title">Categories</h1>
			<ul>
					<li class="cat-item cat-item-64848"><a href="https://charity.wtf/category/acquisitions/">acquisitions</a>
</li>
	<li class="cat-item cat-item-144203"><a href="https://charity.wtf/category/aws/">aws</a>
</li>
	<li class="cat-item cat-item-433547655"><a href="https://charity.wtf/category/books/">books</a>
</li>
	<li class="cat-item cat-item-10286"><a href="https://charity.wtf/category/databases/">databases</a>
</li>
	<li class="cat-item cat-item-28070474"><a href="https://charity.wtf/category/devops/">devops</a>
</li>
	<li class="cat-item cat-item-4236"><a href="https://charity.wtf/category/management/">management</a>
</li>
	<li class="cat-item cat-item-16279507"><a href="https://charity.wtf/category/observability/">observability</a>
</li>
	<li class="cat-item cat-item-28285"><a href="https://charity.wtf/category/operations/">operations</a>
</li>
	<li class="cat-item cat-item-801"><a href="https://charity.wtf/category/security/">security</a>
</li>
	<li class="cat-item cat-item-2092318"><a href="https://charity.wtf/category/serverless/">serverless</a>
</li>
	<li class="cat-item cat-item-451359"><a href="https://charity.wtf/category/sre/">sre</a>
</li>
	<li class="cat-item cat-item-4621"><a href="https://charity.wtf/category/startup/">startup</a>
</li>
	<li class="cat-item cat-item-199524"><a href="https://charity.wtf/category/tech-culture/">tech culture</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://charity.wtf/category/uncategorized/">Uncategorized</a>
</li>
	<li class="cat-item cat-item-136324"><a href="https://charity.wtf/category/vendor/">vendor</a>
</li>
			</ul>

			</aside><aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://charity.wtf/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="meta-2" class="widget widget_meta"><h1 class="widget-title">Meta</h1>
		<ul>
						<li><a href="https://charity.wtf/wp-login.php">Log in</a></li>
			<li><a href="https://charity.wtf/feed/">Entries feed</a></li>
			<li><a href="https://charity.wtf/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside></div><!-- #secondary -->

		</div>
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-7561" class="post-7561 post type-post status-publish format-standard hentry category-management category-startup category-tech-culture">
	<header class="entry-header">
		<h1 class="entry-title">How can you tell if the company you&#8217;re interviewing with is rotten on the inside?</h1>
		<div class="entry-meta">
			<span class="posted-on"><a href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/" rel="bookmark"><time class="entry-date published" datetime="2022-01-29T02:05:52+00:00">January 29, 2022</time><time class="updated" datetime="2022-01-29T05:55:24+00:00">January 29, 2022</time></a></span><span class="byline"> <span class="author vcard"><a class="url fn n" href="https://charity.wtf/author/mipsytipsy/">mipsytipsy</a></span></span>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->

	<div class="entry-content">
		<p>How can you tell the companies who are earnestly trying to improve apart from the ones who sound all polished and healthy from the outside, whilst rotting on the inside?</p>
<p>This seems to be on a lot of minds right now, what with the Great Resignation and all. There are no perfect companies, just like there are no perfect relationships; but there are many questions and techniques you can use to increase your confidence that a particular company is decent and self-aware, one whose quirks and foibles you are compatible with.</p>
<blockquote class="twitter-tweet" data-conversation="none" data-width="550" data-lang="en" data-dnt="true" data-partner="jetpack"><p lang="en" dir="ltr">There&#39;s an asymmetry of information that makes it very challenging to pick between the companies that are earnestly trying to do better and the ones that say the right things but are actively evil.</p>&mdash; riri 🏳️‍🌈⚧️ (@rainbowthirsty) <a href="https://twitter.com/rainbowthirsty/status/1486212123525287938?ref_src=twsrc%5Etfw">January 26, 2022</a></blockquote>
<p>Interviews are designed to make you feel like you are under inspection, like the interviewer holds all the power. This is an illusion. Your labor is valuable — it is <em>vital</em> — and you should be scrutinizing them every bit as closely as they you. In fact, here is Tip #1:</p>
<ul>
<li>If they allow you plenty of time to converse with your interviewers throughout the process, great. If they tack on a cursory “any questions for us?” while wrapping up, they don&#8217;t think it matters what you think of them. Pull the ripcord.</li>
</ul>
<p>Collect and practice good interview questions for you to ask potential employers. Write them down &#8212; your mind is likely to go blank under stress, and you don&#8217;t want to let them off the hook. There is a LOT of signal to be gained by probing down below the surface answers.</p>
<h3>Backchanneling</h3>
<ol>
<li>Whisper networks and backchannels are incredibly important. It can be especially valuable to talk to someone who has recently left the company: why did they leave? Would they go there again?</li>
<li>Alternately, do you know anyone who has worked for or with their leadership, even if not at that company?</li>
<li>If you know any women or under-represented minorities (URM) who work there, buy them lunch and ask for the unvarnished truth. That’s where you usually turn up the <em>real</em> dirt. 🥂</li>
</ol>
<h3>Diversity, equity and inclusion</h3>
<p>Just because a company has a diverse workforce doesn’t necessarily mean it is a healthy place to work. (But it&#8217;s fair to give some points up front, because that doesn’t usually happen by accident.)</p>
<ol>
<li>Do they have a diverse leadership team? A diverse board?<img data-attachment-id="7507" data-permalink="https://charity.wtf/9379ed1e-17f5-459f-adb4-c00f26850ee6_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=1024%2C1024&amp;ssl=1" data-orig-size="1024,1024" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c" data-image-description data-image-caption data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" class="wp-image-7507 alignright jetpack-lazy-image" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=185%2C185&#038;ssl=1" alt width="185" height="185" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?w=1024&amp;ssl=1 1024w" data-lazy-sizes="(max-width: 185px) 100vw, 185px" data-lazy-src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=185%2C185&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="7507" data-permalink="https://charity.wtf/9379ed1e-17f5-459f-adb4-c00f26850ee6_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=1024%2C1024&amp;ssl=1" data-orig-size="1024,1024" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" class="wp-image-7507 alignright" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=185%2C185&#038;ssl=1" alt="" width="185" height="185" srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/9379ED1E-17F5-459F-ADB4-C00F26850EE6_1_105_c.jpeg?w=1024&amp;ssl=1 1024w" sizes="(max-width: 185px) 100vw, 185px" data-recalc-dims="1" /></noscript></li>
<li>Is their company diverse overall, or are minorities concentrated in a few (lower-paying, high-turnover) departments?</li>
<li>You might not want to write off all the companies that don’t meet points one and two, if for no other reason than it dramatically shrinks your available option pool. If they <em>don’t</em> have a particularly diverse team, and this is something that matters to you, that&#8217;s your cue to dig deeper:
<ul>
<li>Are they bothered by their lack of diversity? What&#8217;s the plan? Do they just feel generically sad about it, or have they set specific goals to improve by specific dates? What investments are they making?</li>
<li>Who works on DEI stuff currently? (Answers like “HR and recruiting”, or “we have a woman who’s really good at it” are bad answers.)</li>
<li>Who is accountable for making sure those goals are hit? (The only right answer is “our execs”. Having a &#8220;chief diversity officer&#8221; is an anti-pattern in my book.)</li>
<li>If the team is all guys, for example, ask if they’ve ever had any women on the team in the past. Did she/they leave? Do they know why?</li>
</ul>
</li>
<li>This is a GREAT one: &#8220;As a white man, I&#8217;d ask what they&#8217;ve done to find qualified women and minorities for the role I&#8217;m interviewing for.&#8221; (<a href="https://twitter.com/DavidDaly44/status/1487255595715596293?s=20&amp;t=pSVJaVTH0TDubiJBNyEhtQ">via David Daly</a>) 🔥🔥</li>
</ol>
<h3>Company stuff</h3>
<ol>
<li>What are their values? Do they feel bloodless and ripped from the pages of HBR, or are they unique, lived-in, and give you a glimpse of what the people there care about? Are they mentioned over the course of your interview?</li>
<li>Ask tough questions about the business and try to ascertain whether they are hitting their quarterly goals, how much funding they have in the bank, what the growth curve looks like, what users really think about their product, and what the biggest obstacles to success are.
<ul>
<li>Companies that are floundering are going to be really stressful places to work, and even if the leadership is decent, they may find themselves backed into making some really tough decisions.</li>
<li>You want to work at a company on a strong growth trajectory for <em>lots</em> of reasons, but a big one is your own growth potential. You will learn the most the fastest at places that are growing fast, and have way more openings for promotions and leadership roles than a slower-growing company.</li>
</ul>
</li>
<li>Are people willing to speak freely about things they’ve tried that have failed, and things that don’t work well currently? Being self-aware and comfortable with <strong>visible failure </strong>are two of the most important self-correcting mechanisms a company can cultivate.</li>
<li>EVERYBODY thinks they value transparency, so I wouldn&#8217;t even bother asking. <img data-attachment-id="7501" data-permalink="https://charity.wtf/21ef5b18-b4a8-4d3c-b8e8-b15e3d9aaf0f_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=960%2C960&amp;ssl=1" data-orig-size="960,960" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c" data-image-description data-image-caption data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="alignleft wp-image-7501 jetpack-lazy-image" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=185%2C185&#038;ssl=1" alt width="185" height="185" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?w=960&amp;ssl=1 960w" data-lazy-sizes="(max-width: 185px) 100vw, 185px" data-lazy-src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=185%2C185&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="7501" data-permalink="https://charity.wtf/21ef5b18-b4a8-4d3c-b8e8-b15e3d9aaf0f_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=960%2C960&amp;ssl=1" data-orig-size="960,960" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="alignleft wp-image-7501" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=185%2C185&#038;ssl=1" alt="" width="185" height="185" srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/21EF5B18-B4A8-4D3C-B8E8-B15E3D9AAF0F_1_105_c.jpeg?w=960&amp;ssl=1 960w" sizes="(max-width: 185px) 100vw, 185px" data-recalc-dims="1" /></noscript>Instead, ask for specific examples of leadership being forthcoming with bad news to the team, and team members delivering hard feedback or bad news to upper leadership. Transparency shouldn’t be something they’re especially proud of, so much as it is taken for granted. It’s in the air that you breathe.</li>
</ol>
<h3>Planning and the unplanned</h3>
<ol>
<li>Ask about how decisions get made. A chestnut is, “how does work end up on my plate?” — meaning is there a business strategy (owned by whom?), a technical strategy, a product strategy, quarterly KPIs, customer requests, manager delegation, JIRA tickets&#8230;? (The most important part may be how similar the answers you get are. 🙃)</li>
<li>How often does work get pre-empted and why? It’s a <em>good</em> thing if product development has to get put on ice once in a while so the team can focus on reliability and maintenance work. It’s a bad thing if they’re expected to stuff reliability work in the cracks around their product development, or if they&#8217;re incapable of sticking to a plan.</li>
<li>What does “<strong>crunch time</strong>” look like? Nearly every company has one from time to time (it might even be a bad sign if it <em>never</em> happens), but this is when you find out your leadership’s true colors.
<ul>
<li>Do they praise people or call them out to thank them for pulling all nighters and other extremist behaviors? 🚨BZZT<strong>🚨</strong></li>
<li>Is it voluntary? Are you trusted to set your own pace, your own limits, or are you pressured to do more? Are people expected to participate to the extent that they are able, and not expected to justify how hard or how much (so long as they communicate their capacity, of course)?<img data-attachment-id="7490" data-permalink="https://charity.wtf/5ea93f7b-9a28-4b3f-8a94-26b73c98119b_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=875%2C897&amp;ssl=1" data-orig-size="875,897" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c" data-image-description data-image-caption data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=293%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=660%2C677&amp;ssl=1" loading="lazy" class="wp-image-7490 alignright jetpack-lazy-image" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=187%2C191&#038;ssl=1" alt width="187" height="191" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=293%2C300&amp;ssl=1 293w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=768%2C787&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?w=875&amp;ssl=1 875w" data-lazy-sizes="(max-width: 187px) 100vw, 187px" data-lazy-src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=187%2C191&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="7490" data-permalink="https://charity.wtf/5ea93f7b-9a28-4b3f-8a94-26b73c98119b_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=875%2C897&amp;ssl=1" data-orig-size="875,897" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=293%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?fit=660%2C677&amp;ssl=1" loading="lazy" class="wp-image-7490 alignright" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=187%2C191&#038;ssl=1" alt="" width="187" height="191" srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=293%2C300&amp;ssl=1 293w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?resize=768%2C787&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/5EA93F7B-9A28-4B3F-8A94-26B73C98119B_1_105_c.jpeg?w=875&amp;ssl=1 875w" sizes="(max-width: 187px) 100vw, 187px" data-recalc-dims="1" /></noscript></li>
<li>How long did it last, and how often does it happen, and why? It should be rare (1-2x/year at most), involve the whole company, and move the business forward meaningfully</li>
<li>Did they follow through by making sure people took time off afterwards to recover? Not just give permission, but actually make sure the human beings had a chance to refresh themselves? Did leaders set a good example by taking a breather themselves?</li>
</ul>
</li>
</ol>
<p>Believe it or not, crunch time done correctly can be an enormously <strong>exciting, intense, bonding time</strong> for a group of people who love what they do, culminating in a surge of collective triumph and celebration, followed by recovery time. If it was done correctly, and you ask about it afterwards, people will 💡light up💡.</p>
<h3>Team stuff</h3>
<ol>
<li>Unfortunately, culture can vary widely from function to function, even from manager to manager. Make sure you get a real interview slot with <strong>your actual manager</strong> — not just a screener or wrap-up call — and as much of the team as possible, too.</li>
<li>Ask your potential manager about the last person they had to let go. Why? What was the process? What was the impact on the team? How did the person feel afterwards?</li>
<li>Who is on call? How often do people get paged outside of hours, and how frequently do they work an incident? (Do managers track this?) Are you expected to keep shipping product during on call weeks, or devote your time to making the system better?</li>
<li>If you had to ship a single line of code to production using the deploy pipeline, how long would that take? Remember, the <strong>lower the deploy interval</strong>, the happier and more productive you are likely to be as an engineer there. Under 15 minutes is great. Under an hour is tolerable. More than that, proceed with great caution.</li>
</ol>
<h3>The interview itself</h3>
<ol>
<li>Was your interview well-organized and conducted in a timely fashion? Were you given detailed information about what to expect, and were your interviewers well-prepared, and conversational? Were the questions fair, open-ended, and <img data-attachment-id="7489" data-permalink="https://charity.wtf/caf44674-65da-4054-8693-6942dedc1284_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=1000%2C1000&amp;ssl=1" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c" data-image-description data-image-caption data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="wp-image-7489 alignright jetpack-lazy-image" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=186%2C186&#038;ssl=1" alt width="186" height="186" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?w=1000&amp;ssl=1 1000w" data-lazy-sizes="(max-width: 186px) 100vw, 186px" data-lazy-src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=186%2C186&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="7489" data-permalink="https://charity.wtf/caf44674-65da-4054-8693-6942dedc1284_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=1000%2C1000&amp;ssl=1" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="wp-image-7489 alignright" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=186%2C186&#038;ssl=1" alt="" width="186" height="186" srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=768%2C768&amp;ssl=1 768w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=800%2C800&amp;ssl=1 800w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/CAF44674-65DA-4054-8693-6942DEDC1284_1_105_c.jpeg?w=1000&amp;ssl=1 1000w" sizes="(max-width: 186px) 100vw, 186px" data-recalc-dims="1" /></noscript>relevant to the job in question?</li>
<li>If they asked you to perform any kind of take-home labor of more than an hour or so, did they <strong>compensate you</strong> for your time?</li>
<li>Did they get back to you swiftly at each step of the way to let you know where you stand and what comes next?</li>
<li>Did you find the questions interesting and challenging? Do they have a clear idea of what success looks like for you in this role? Did you leave excited and buzzing with ideas about the work you could do together?
<ul>
<li>This is 👆 definitely more of a “how good is this job” question than “is this a shithole” question, but one of our honeycombers brought it up as an example of how a great interview can make you decide to leave a job , even one you’re perfectly happy with.</li>
</ul>
</li>
<li><strong>The questions they ask you while interviewing you are the questions they ask everyone else</strong>. So&#8230;did they ask you about your views on diversity and team dynamics while interviewing you? Or is that not part of their filters, only their advertised persona?</li>
</ol>
<h3>Three more</h3>
<ol>
<li>Do their employees seem to speak freely on twitter? If you are an agitator of sorts, are there others who agitate about similar issues — either with company support, or at least lack of censorship?</li>
<li>How does the company respond to criticism and feedback? For that matter, how do they treat their competitors? Being competitive is fine, being mean is not.</li>
<li>Get clear on <strong>your own expectations</strong>. What’s on your wishlist, and what’s make-or-break for you? If something is very important to you, consider telling the hiring manager up front. For example, “These are my expectations for how women are treated. How do you think your company matches up?” Their answers will speak volumes, and so will their comfort level with the question.</li>
</ol>
<h3>In closing</h3>
<p>If you a join a new company, and two or three weeks in you&#8217;re just not feeling it, you&#8217;re wondering if you made a mistake &#8212; <em>leave</em>. <strong>You do not owe them a year of your life</strong>. Trust your instincts. Just leave it off your resume entirely and roll the dice again.</p>
<p>Employers are all too accustomed to feeling (and acting) like they hold all the power. They do not. Every tech company is a talent business, which rises and falls on the caliber of the<img data-attachment-id="7495" data-permalink="https://charity.wtf/65f84801-cc7a-4afe-9fa3-bb0f6c461995_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=753%2C753&amp;ssl=1" data-orig-size="753,753" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c" data-image-description data-image-caption data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="wp-image-7495 alignleft jetpack-lazy-image" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=187%2C187&#038;ssl=1" alt width="187" height="187" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?w=753&amp;ssl=1 753w" data-lazy-sizes="(max-width: 187px) 100vw, 187px" data-lazy-src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=187%2C187&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="7495" data-permalink="https://charity.wtf/65f84801-cc7a-4afe-9fa3-bb0f6c461995_1_105_c/" data-orig-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=753%2C753&amp;ssl=1" data-orig-size="753,753" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=300%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?fit=660%2C660&amp;ssl=1" loading="lazy" class="wp-image-7495 alignleft" src="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=187%2C187&#038;ssl=1" alt="" width="187" height="187" srcset="https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=150%2C150&amp;ssl=1 150w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/charity.wtf/wp-content/uploads/2022/01/65F84801-CC7A-4AFE-9FA3-BB0F6C461995_1_105_c.jpeg?w=753&amp;ssl=1 753w" sizes="(max-width: 187px) 100vw, 187px" data-recalc-dims="1" /></noscript> people they can convince to stay. They aren’t doing you a favor by employing you; you are doing THEM a favor by lending them your creativity, labor, and a third of the hours in your day.</p>
<p>Do they deserve it? Will their success make the world a better place? If not, stop supporting them with your work and lend your muscle to a company that deserves it.</p>
<p>In the hottest job market of my lifetime, with millions of opportunities newly open to people who live literally anywhere, you owe it to yourself, your future self, and your family to take a good hard look at where you sit. 🍄 Are you happy? 🍄 Are you compensated well, is your time valued? 🍄 Are you still learning new things and improving your skills every day? 🍄 Is your company still on a growth trajectory? 🍄 Do you trust your leadership and your team, 🍄 do still you believe in the mission, and 🍄 do you think your labor contributes meaningfully to making the world a better place?</p>
<p>If not, consider joining the Great Resignation. I hear they have cookies.</p>
<p><em>Huge thanks to <a href="http://twitter.com/amydavis_sv">Amy Davis</a>, <a href="http://twitter.com/cartermp">Phillip Carter</a>, <a href="http://twitter.com/metaforgotten">Ian Smith</a>, <a href="http://twitter.com/sarahvoegeli">Sarah Voegeli</a>, <a href="http://twitter.com/kentquirk">Kent Quirk</a>, <a href="http://twitter.com/lizthegrey">Liz Fong-Jones</a>, Amanda Shapiro, <a href="http://twitter.com/rycar">Nick Rycar</a>, <a href="http://twitter.com/mononcqc">Fred Hebert</a> and <a href="http://twitter.com/DavidDaly44">David Daly</a>, all of whom contributed to this post!</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-7561" class="share-twitter sd-button share-icon" href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-7561" class="share-facebook sd-button share-icon" href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-104471542-7561-61f83651bb848' data-src='https://widgets.wp.com/likes/#blog_id=104471542&amp;post_id=7561&amp;origin=charity.wtf&amp;obj_id=104471542-7561-61f83651bb848' data-name='like-post-frame-104471542-7561-61f83651bb848' data-title='Like or Reblog'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			</div><!-- .entry-content -->

	<div class="entry-format">
		<a href="https://charity.wtf/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/"><span class="screen-reader-text">How can you tell if the company you&#8217;re interviewing with is rotten on the inside?</span></a>	</div>
</article><!-- #post-## -->

				<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<div class="nav-previous"><a href="https://charity.wtf/2022/01/20/how-engineering-driven-leads-to-engineering-supremacy/" rel="prev"><span class="meta-nav">&larr;</span>&nbsp;How &#8220;Engineering-Driven&#8221; Leads to &#8220;Engineering-Supremacy&#8221;</a></div>		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
			
<div id="comments" class="comments-area">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/01/29/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=104471542&#038;postid=7561&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=10.6-beta&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=df71e8f7a2fcb02bade491d34755830aafb8a0d4#parent=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
			<a href="https://wordpress.com/?ref=footer_custom_powered">Powered by WordPress.com</a>.
			
					</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202205'></script>
		<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=10.6-beta' id='twitter-widgets-js'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/charity.wtf\/2022\/01\/29\/how-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside\/":7561};
	</script>
				<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/coblocks/dist/js/coblocks-animation.js?ver=2.19.1' id='coblocks-animation-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/themes/minnow/js/minnow.js?ver=20141015' id='minnow-script-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/themes/minnow/js/navigation.js?ver=20120206' id='minnow-navigation-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/themes/minnow/js/skip-link-focus-fix.js?ver=20130115' id='minnow-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.9/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=ba2aa80003251440130b63de19cb609d' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=ae8c0bea6a07ab76470a02053fc74216' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=10.6-beta' id='jetpack_likes_queuehandler-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/charity.wtf\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/charity.wtf\/wp-admin\/admin-ajax.php","nonce":"0d8bcb74c7","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/charity.wtf\/wp-login.php?redirect_to=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.6-beta' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://charity.wtf/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.6-beta' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202205#ver=202205' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=104471542&postid=7561&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.6-beta&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=df71e8f7a2fcb02bade491d34755830aafb8a0d4#parent=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=104471542&postid=7561&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=10.6-beta&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=df71e8f7a2fcb02bade491d34755830aafb8a0d4#parent=https%3A%2F%2Fcharity.wtf%2F2022%2F01%2F29%2Fhow-can-you-tell-if-the-company-youre-interviewing-with-is-rotten-on-the-inside%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								frame.style.height = event.data + 'px';
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202205.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6-beta',blog:'104471542',post:'7561',tz:'0',srv:'charity.wtf'} ]);
	_stq.push([ 'clickTrackerInit', '104471542', '7561' ]);
</script>

</body>
</html>
<!--
	generated 175 seconds ago
	generated in 0.196 seconds
	served from batcache in 0.002 seconds
	expires in 125 seconds
-->
